Главная | Обратная связь
МегаЛекции

Формулы экранной формы задачи




Объект математической модели Выражение в Excel
Формула ЦФ в целевой ячейке В20 =СУММПРОИЗВ(C3:E6;C13:E16)
Ограничения по строкам в ячейках F3 F4 F5 F6 =СУММ(C3:E3) =СУММ (C4:E4) =СУММ (C5:E5) =СУММ (C6:E6)
Ограничения по столбцам в ячейках C8 D8 E8 =СУММ(C3:C6) =СУММ(D3:D6) =СУММ(E3:E6)

В экранной форме (Рис.21) в ячейках F3, F4, F5, F6, C8, D8, E8, B20 появится текущее значение, вычисленное по введенной формуле, то есть 0 (так как в момент ввода формулы значение переменных задачи нулевые).

5. Осуществите поиск решения задачи, для этого:

· Зайдите в меню Сервис→Поиск решения;

· В поле направление оптимизации ЦФ, щелкнув один раз левой клавишей мыши по кнопке«минимальному значению»;

· Укажите диапазон изменения ячеек, для этого в окне в поле «Изменяя ячейки» впишите адреса $C$3:$E$6;

· Внесите ограничения, накладываемые на условие задачи (Рис.22);

· Запустите «Поиск решения», нажав на кнопку «Выполнить».

Рис. 22. Ограничения и граничные условия задачи

6. Проанализируйте полученный результат (Рис.26).

 

Рис. 23. Решение транспортной задачи

Вывод:с 1-го склада в первый магазин надо перевести 25 шт. товара, со 2-го склада во второй магазин надо перевести 50 шт. товара, с 3-го склада во второй магазин надо перевести 35 шт. товара, с 4-го склада в первый магазин 20 шт., во второй – 5 шт., в третий магазин – 50 шт. товара, общая стоимость перевозки будет равна 545 рублей.

Задание 12

Сохраните файл в своей папке с именем lab_3(a).

Решение несбалансированной транспортной задачи

Пусть необходимо организовать оптимальные по транспортным расходам перевозки муки с двух складов в три пекарни. Ежемесячные запасы муки на складах (т), ежемесячные потребности хлебопекарни (т) и транспортные расходы (руб./т) по доставке муки представлены в таблице (Таблица 21). В связи с ремонтными работами временно не возможна перевозка из второго склада в третью хлебопекарню.

Таблица 21

Транспортные расходы по доставке муки (руб./т)

  Хлебопекарни Запас, мешки
Склады Х1 Х2 Х3
С1
С2 ремонт
Потребность, мешки  

Построение модели

Построим математическую модель для данной транспортной задачи.





Читайте также:





©2015- 2017 megalektsii.ru Все авторские права принадлежат авторам лекционных материалов.