Главная | Обратная связь
МегаЛекции

Проверка статистических свойств остатков (качества оценок коэффициентов регрессии)





 

Центрированность остатков

Для проверки гипотезы о значимости математического ожидания случайной переменной , выборочными оценками которой являются остатки, сравниваются наблюдаемое и критическое значения t-статистики.

На листе «Регрессия» в ячейку D25 введите название «Условие 1».

В ячейку D41 введите tнабл. В ячейку E41 введите формулу = (Е28 – 0)*КОРЕНЬ(Е40)/Е32 для подсчета наблюдаемого значения статистики tнабл. В ячейку D42 введите tкр. В ячейку E42 введите формулу = СТЬЮДРАСПОБР(0,05;20 – 1) для подсчета критической точки распределения Стьюдента tкр.

 

Гомоскедастичность (гетероскедастичность) остатков

Для проверки гипотезы о гомоскедастичности случайной переменной сравниваются наблюдаемое и критическое значения t-статистики.

Найдите наблюдаемое значение t-статистики по формуле

,

где – коэффициент ранговой корреляции Спирмена;

Di – разность между рангом xi и рангом модуля остатка ei.

На листе «Исходные данные» содержимое ячеек A1:A21 скопируйте в ячейку A1 нового листа и назовите лист «Условие 2». В ячейку В1 скопируйте из листа «Регрессия» столбец «Остатки» вместе с названием. В ячейку С1 введите название «Модуль ост». В ячейки С2:С21 введите формулу массива {= ABS(B2:B21)} (выделите ячейки С2:С21, нажмите клавишу F2, введите формулу, нажмите комбинацию клавиш Ctrl + Shift + Enter).

Выберите в опциях меню Сервис ® Анализ данных ® Ранг и персентиль ® ОК и заполните диалоговое окно следующим образом:

· Входной интервал – введите ссылки на ячейки A1:A21;

· Метки – установите флажок;

· Выходной интервал –ячейка D1. Нажмите кнопку ОК.

Выберите в опциях меню Сервис ® Анализ данных ® Ранг и персентиль ® ОК и заполните диалоговое окно следующим образом:

· Входной интервал – введите ссылки на ячейки С1:С21;

· Метки – установите флажок;

· Выходной интервал –ячейка Н1. Нажмите кнопку ОК.

Выделите ячейки D2:G21 и нажмите кнопку Сортировка по возрастанию на панели инструментов. Выделите ячейки H2:K21 и нажмите кнопку Сортировка по возрастанию. В ячейки L2:L21 введите формулу массива {= (F2:F21 – J2:J21)^2}. В ячейку L1 введите название «Квадрат разности рангов».



В ячейку K22 введите tнабл. В ячейку L22 введите формулу
= (1 – 6*СУММ(L2:L21)/(20*(20^2 – 1)))*КОРЕНЬ(20 – 1) для вычисления tнабл.

В ячейку K23 введите tкр. В ячейку L23 введите формулу
= СТЬЮДРАСПОБР(0,05;20 – 2) для вычисления tкр.

 

Автокорреляция остатков

Для проверки гипотезы об отсутствии автокорреляции случайной переменной сравниваются наблюдаемое и критические значения статистики Дарбина–Уотсона.

Найдите наблюдаемое значение статистики , используя в качестве оценок значений случайной переменной соответствующие значения остатков, выполнив действия, приведенные ниже.

На листе «Регрессия» в ячейку F25 введите название «Условие 3».

В ячейки F26:F44 введите формулу массива

{= (C26:C44 – C27:C45)^2}.

В ячейку F46 введите формулу = СУММ(F26:F44).

В ячейки G26:G45 введите формулу массива {= (C26:C45)^2}.

В ячейку G46 введите формулу = СУММ(G26:G45).

В ячейку F47 введите dнабл.

В ячейку G47 введите формулу = F46/G46 для вычисления dнабл.

Если критерий Дарбина–Уотсона не дает ответа о наличии автокорреляции, то можно воспользоваться визуальным способом анализа графика зависимости остатков от номера наблюдения, построенного
с помощью диаграммы.

Для построения графика остатков выполните следующие действия:

· на панели инструментов активизируйте кнопку Мастер диаграмм (шаг 1 из 4), в одноименном диалоговом окне среди стандартных типов выберите Точечная, в первой строке первый вид и нажмите кнопку Далее>;

· открывается диалоговое окно Мастер диаграмм (шаг 2 из 4),
в котором во вкладке Диапазон данных в поле Диапазон введите ссылку на диапазон ячеек С26:С45, нажмите кнопку Далее>;

· откройте диалоговое окно Мастер диаграмм (шаг 3 из 4), в котором во вкладке Заголовки в поле Название диаграммы введитеназвание «График остатков»,в поле Ось Х(категорий) – название «Номер наблюдения», в поле Ось Y(значений) – название «Остатки», во вкладке Легенда снимите флажок Добавить легенду и нажмите кнопку Далее>;

· в открывшемся диалоговом окне Мастер диаграмм (шаг 4 из 4)
в поле имеющемся установите флажок, нажмите кнопку Готово.

 

Примечание – Выводы о выполнении условий Гаусса–Маркова подробно описаны в разделе «Эконометрический анализ построения модели множественной регрессии».

 

Анализ свойств модели

 

4.5.1. Мультиколлинеарность факторов: выявление зависимости объясняющих факторов

Для проверки гипотезы об отсутствии мультиколлинеарности используется статистика хи-квадрат с степенями свободы, наблюдаемое значение которой определяется по формуле

где n – количество наблюдений;

p – число независимых переменных.

Dr – определитель матрицы парных коэффициентов корреляции между факторами.

На листе «Исходные данные» в ячейку Е11 введите название «Мультиколлинеарность».

В ячейку Е12 введите название «Определитель».

В ячейку F12 введите математическую формулу

= МОПРЕД(G4:H5).

В ячейку Е13 введите название «хи-кв набл».

В ячейку F13 введите формулу = 20 – 1 – 9*LOG(F12;10)/6 для нахождения хи-квадрат, наблюдаемого по выборке.

В ячейку Е14 введите название «хи-кв кр».

В ячейку F14 введите формулу = ХИ2ОБР(0,05;20*(20 – 1)/2) для нахождения хи-квадрат критического.

 

Эластичность

Средний коэффициент эластичности для i-го фактора линейной регрессии рассчитывается по формуле

.

На листе «Исходные данные» в ячейку А23 введите название «Эластичность».

В ячейку А24 введите название «Фактор у_ср».

В ячейку А25 введите формулу = СРЗНАЧ(А2:А21).

В ячейку В24 введите название «Фактор х1_ср».

В ячейку В25 введите формулу = СРЗНАЧ(В2:В21).

В ячейку С24 введите название «Фактор х2_ср».

В ячейку С25 введите формулу = СРЗНАЧ(С2:С21).

В ячейку А26 введите название «Коэф. фактора х1». Из листа «Регрессия» скопируйте коэффициент при переменной «Фактор х1» из ячейки В18 в ячейку В26 листа «Исходные данные».

В ячейку А27 введите название «Эластичность фактора х1».

В ячейку В27 введите формулу = В26*В25/А25 для вычисления средней частной эластичности по переменной «Фактор х1».

В ячейку А28 введите название «Коэф. фактора х2». Из листа «Регрессия» скопируйте коэффициент при переменной «Фактор х2» из ячейки В19 в ячейку В28 листа «Исходные данные».

В ячейку А29 введите название «Эластичность фактора х2».

В ячейку В29 введите формулу = В28*С25/А25 для вычисления средней частной эластичности по переменной «Фактор х2».





Рекомендуемые страницы:

Воспользуйтесь поиском по сайту:
©2015- 2021 megalektsii.ru Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав.